Back to overview
Resolved

Customers reporting issues connecting to GitHub repositories

Jul 21, 2026 at 8:31am UTC
Affected services
DeployHQ Main App

Resolved
Jul 21, 2026 at 8:31am UTC

Resolved — GitHub's upstream incident affecting deploy-key SSH connections has been resolved (githubstatus.com: All Systems Operational). DeployHQ deploys, repository connections, and pulls using deploy keys are working again; last failure at 11:43 UTC, none since. No action needed from customers. Root cause was on GitHub's side, not DeployHQ.